Manažerská informatika 3MA381
Domů  |  3MA112  |  3MA191  |  3MA381  |  3MA382  |  3MA481   
Osnova cvičení Úvodní informace Harmonogram prezentací Hodnocení Podklady ke cvičením Teorie Domácí cvičeníExtra aktivity Odkazy

Graf-negraf pomocí funkce OPAKOVAT

Pomocí funkce OPAKOVAT můžeme přímo v listu graficky vyjádřit data bez využití grafu.

Funkce OPAKOVAT - výsledek

Postup

Vyjdeme z tabulky, kde máme zaznamenané údaje o hospodářských výsledcích podniku za jednotlivé měsíce roku 2007.

Období Náklady Výnosy Saldo
leden 2007 13 178 44 486 31 308
únor 2007 40 298 13 568 -26 730
březen 2007 24 683 40 387 15 704
duben 2007 37 697 48 804 11 107
květen 2007 46 245 16 202 -30 043
červen 2007 33 837 48 345 14 508
červenec 2007 37 224 19 388 -17 836
srpen 2007 25 435 17 346 -8 089
září 2007 47 275 34 984 -12 291
říjen 2007 36 053 27 393 -8 660
listopad 2007 17 349 27 933 10 584
prosinec 2007 27 572 27 124 -448
Rok 2007 celkem: 386 846 365 960 -20 886

Jestliže saldo máme ve sloupci D, pak do buňky ve sloupci Ztráta zapíšeme vzorec:

=KDYŽ($D2<0;OPAKOVAT("|";-ZAOKROUHLIT($D2/1000;0));"")

Vzorec vypíše pro všechny záporné hodnoty odpovídající počet svislých čar v poměru 1:1000.

Dále nastavíme takový typ písma, aby byly svislé čáry blízko sobě. Pro tento účel by se hodilo například písmo Arial Black, Arial Narrow, System, Tunga a podobné. Případně můžeme nastavit písmo na tučné.

Ve sloupci Zisk pak bude obdobný vzorec, s tím, že zarovnání textu v buňce nastavíme vodorovně vlevo.

=KDYŽ($D2>0;OPAKOVAT("|";ZAOKROUHLIT($D2/1000;0));"")

Obdobným způsobem bychom mohli vkládat místo svislých čar do buněk obrázky použitím např. písma Webdings nebo Wingdings.

© 2007–2013 Miroslav Lorenc

Převzetí, publikování, kopírování, či jiné užití než pro osobní potřebu je možné pouze s písemným svolením autora.