Manažerská informatika 3MA381
Domů  |  3MA112  |  3MA191  |  3MA381  |  3MA382  |  3MA481   
Osnova cvičení Úvodní informace Harmonogram prezentací Hodnocení Podklady ke cvičením Teorie Domácí cvičeníExtra aktivity Odkazy

Funkce KDYŽ

Logická funkce KDYŽ je jednou z vůbec nejpoužívanějších funkcí Excelu. Funkce vyhodnocuje podmínku zapsanou v prvním argumentu funkce a vrací hodnotu druhého argumentu v případě, že je podmínka splněna nebo hodnotu třetího (nepovinného) argumentu jestliže podmínka splněna není.

Syntaxe funkce KDYŽ

=KDYŽ(podmínka;ano;ne)

Podmínka je libovolná podmínka nebo výraz, který vrací výsledek PRAVDA nebo NEPRAVDA.

Ano je hodnota, která je vrácena, jestliže hodnota argumentu podmínka je PRAVDA.

Ne je hodnota, která je vrácena, jestliže hodnota argumentu podmínka je NEPRAVDA.

      A B C D
1 10 20 0 =KDYŽ(A1<B1;;)
2 10 20 PRAVDA =KDYŽ(A2<B2;PRAVDA;)
3 10 20 0 =KDYŽ(A3<B3;;NEPRAVDA)
4 10 20 PRAVDA =KDYŽ(A4<B4;PRAVDA;NEPRAVDA)
5 10 20 A je 2*větší =KDYŽ(2*A5=B5;"A je 2*větší";)
6 10 20 =KDYŽ(2*A6=B6;"";"A není 2*větší")
7 10 20 A je 2*větší =KDYŽ(2*A7=B7;"A je 2*větší";"A není 2*větší")
8 10 0 =KDYŽ(B8<>0;A8/B8;"")
9 10   deset =KDYŽ(A9=10;"deset";"není deset")

Jestliže je výsledek NEPRAVDA, pak funkce KDYŽ vrací nulu. Pokud nechceme, aby se nula zobrazovala, můžeme použít prázdný textový řetězec "". Buňka v tom případě zůstane prázdná.

Argument podmínka je většinou logický výraz případně jí může být odkaz na buňku.

Argumenty ano a ne mohou být číslo, text (text musíme psát v uvozovkách), odkaz na buňku, vzorec, funkce Excelu nebo prázdný řetězec.

Vynecháním argumentu ano vrací funkce KDYŽ hodnotu 0 přestože je podmínka splněna.

Vynecháním argumentu ne vrací funkce KDYŽ hodnotu 0 v případě, že jsme za argumentem ano zapsali středník nebo NEPRAVDA jestliže jsme středník nezapsali.

K čemu je to dobré

Související funkce

Příklady

Nahoru

© 2007–2013 Miroslav Lorenc

Převzetí, publikování, kopírování, či jiné užití než pro osobní potřebu je možné pouze s písemným svolením autora.