Manažerská informatika 3MA381
Domů  |  3MA112  |  3MA191  |  3MA381  |  3MA382  |  3MA481   
Osnova cvičení Úvodní informace Harmonogram prezentací Hodnocení Podklady ke cvičením Teorie Domácí cvičeníExtra aktivity Odkazy

Počet obyvatel

V tabulce, která obsahuje velké množství dat - přes 6000 záznamů o pohlaví a rodinném stavu obyvatelstva, potřebujeme zjišťovat počet obyvatel podle různých parametrů.

Cíl cvičení

Ke stažení

Úkoly

1) Sestavte funkci, která vrátí na základě pořadí sloupce v buňce B4 a zadaného města v buňce A4 počet obyvatel v buňce C4.

2) Sestavte funkci, která vrátí na základě pořadí řádku v buňce A5 a kategorie vybrané z rozvíracího seznamu v buňce B5 počet obyvatel v buňce C5.

3) Upravte funkci v buňce C4 tak, aby stačilo zapsat v buňce B4 slovní kategorii (rozvedení, rozvedené, ženatí, vdané apod.) resp. v buňce A5 název města.

4) Pro zadávání slovních parametrů vyhledávání použijte možnost ověření dat – rozvírací seznam v buňce.

Řešení

1) Pro vyhledávání podle pořadí sloupce v tabulce s údaji se výborně hodí funkce SVYHLEDAT.

      A B C D
3 Obec Kategorie Obyvatel Vzorec ve sloupci C
4 Abertamy 4 316 =SVYHLEDAT(A4;A12:M6269;B4;NEPRAVDA)

2) Obdobně jako v prvním úkolu jde využít funkce VVYHLEDAT.

      A B C D
3 Obec Kategorie Obyvatel Vzorec ve sloupci C
4 Abertamy 4 316 =SVYHLEDAT(A4;A12:M6269;B4;NEPRAVDA)
5 6 celkem 508 =VVYHLEDAT(B5;A11:M6269;A5;NEPRAVDA)

3) Standardně lze ve funkcích SVYHLEDAT a VVYHLEDAT zadávat pouze číslo sloupce resp. řádku, podle kterého chceme vyhledávat. To činí zápis funkce přehlednější, ale výsledná tabulka není pro člověka dobře čitelná. Pokud chceme zadávat místo čísel slovní údaje, budeme potřebovat nahradit číslo za funkci, která vrátí po zadání slovního údaje číslo sloupce resp. řádku, ve kterém se údaj nachází. K tomu může posloužit funkce POZVYHLEDAT. Ve funkci tedy nahradíme odkaz na buňku B4 resp. A5 za funkci POZVYHLEDAT, která vrátí číslo sloupce resp. řádku.

      A B C D
3 Obec Kategorie Obyvatel Vzorec ve sloupci C
4 Abertamy svobodní 316 =SVYHLEDAT(A4;A12:M6269;POZVYHLEDAT(B4;A11:M11;0);NEPRAVDA)
5 Adršpach celkem 508 =VVYHLEDAT(B5;A11:M6269;POZVYHLEDAT(A5;A11:A6269;0);NEPRAVDA)

4) Abychom nemuseli slovní údaje vypisovat ručně a také proto, abychom předešli překlepům a dalším chybám, můžeme do příslušných buněk zadat ověření dat s volbou rozvíracího seznamu v buňce. Pro další zjednodušení bude vhodné si pojmenovat zdrojovou tabulku, oblasti s názvy kategorií a obcí.

      A B C D
3 Obec Kategorie Obyvatel Vzorec ve sloupci C
4 Abertamy svobodní 316 =SVYHLEDAT(A4;A12:M6269;POZVYHLEDAT(B4;kategorie;0);NEPRAVDA)
5 Adršpach celkem 508 =VVYHLEDAT(B5;A11:M6269;POZVYHLEDAT(A5;obec;0);NEPRAVDA)

K úvaze

Jak vyřešíte konflikt ve shodných názvech obcí?

© 2007–2013 Miroslav Lorenc

Převzetí, publikování, kopírování, či jiné užití než pro osobní potřebu je možné pouze s písemným svolením autora.